Stamp Community Family of Web Sites
Thousands of stamps, consistently graded, competitively priced and hundreds of in-depth blog posts to read
Stamp Community Forum
 
Username:
Password:
Save Password
Forgot your Password?

Welcome Guest! Need help? Got a question? Inherit some stamps?
Our stamp forum is completely free! Register Now!

Problem Uploading Image

 
To participate in the forum you must log in or register.
Author Previous TopicReplies: 6 / Views: 256Next Topic  
Pillar Of The Community
Learn More...
Canada
578 Posts
Posted 09/17/2020   3:36 pm  Show Profile Bookmark this topic Add itma to your friends list Get a Link to this Message
I sent a message to staff from the topic I just posted on the Australian group. Here is some more info. The message is titled "Acsc 259 1/0 KGV Issue Of 1950" - http://goscf.com/t/74221

Using Firefox 80.0.1 on Windows 10.

Process:
1. start editing a new post.
2. open the upload window but go straight back to main editing window without selecting or sending an image to SCF. (I did not try selecting a file and going back to the editing window without uploading it.)
3. at this point I can no longer access the upload window. The link doesn't work. If I close the main editing window, I can see the upload window but it is totally inoperative. I will need to force close it or reboot.

No problem was experienced when I actually uploaded a file in step 2.

I went through this process again using on Testing channel and the problem replicated the same way.

I then tried it again on the Testing channel using MS Edge without problems.

This is not an urgent problem (unless, I guess, you don't know about the problem).

Send note to Staff

Moderator
Learn More...
8491 Posts
Posted 09/17/2020   4:53 pm  Show Profile Check 51studebaker's eBay Listings Bookmark this reply Add 51studebaker to your friends list  Get a Link to this Reply
Thanks for the troubleshooting and good, descriptive feedback. I have a number of test machines in various configuration around the house but not one with the combination you describe so I am unable to try to replicate the issue. If anyone else reads this has a Windows 10 computer and is running Firefox 80.0.1 browser please let us know if you are seeing the same issue.

I remember when browser-based technology was described as 'write once, run anywhere' but those days are long over; trying to support the endless combinations of device/OS/browsers and all their version iterations has become almost impossible.

Don
Send note to Staff  Go to Top of Page
Pillar Of The Community
Learn More...
Canada
578 Posts
Posted 09/17/2020   7:14 pm  Show Profile Bookmark this reply Add itma to your friends list  Get a Link to this Reply
Don:

I've done a bit more testing and the results suggest something is not quite correct in Firefox 80.0.1.

For the record, let me explicitly say that this problem doesn't happen when you use the upload window's "Close Window" link. I have been getting back to the editor just by clicking on its window. I also extended the test by actually selecting a file to upload before clicking back to the editing window. The results are the same.

I reran my test on Firefox 80.0.1 for macOS and on the iOS (iPad) versions. Both cases are similar to what I reported previously where, following a glance at the upload window and going back to the editing window, you can't get back to the upload window because the "Upload image" link doesn't work. There is a slight difference from the Windows 10 case, as follows:

macOS
As for Windows 10, a pop-up window is created for the Upload task. When I abandon the edit and start a new editing window, the "Upload image" still does not work. The Upload window dies when Firefox is closed down and does not leave an orphaned window.

iOS
The Upload window is created under a new tab in the browser. Otherwise, it works (or doesn't) the same way as for MacOS.

For good measure, I also tested the process on Safari with no problems.

This makes it look as if the problem lies in the way Firefox 80.0.1 hands tasks off between processes. The editing task is obviously looking for a response from the upload window before continuing. If you would like me to take this up with Mozilla, I would be happy to do so.

Frank.




Send note to Staff  Go to Top of Page
Pillar Of The Community
Japan
2287 Posts
Posted 09/17/2020   7:30 pm  Show Profile Bookmark this reply Add PostmasterGS to your friends list  Get a Link to this Reply
I tried recreating the problem on MacOS 10.14.6 with Firefox 80.0.1. Worked fine for me.

EDIT: And I tried on Win 10, Firefox 80.0.1. Again, no issues.
Send note to Staff  Go to Top of Page
Presenting the GermanStamps.net Collection - Germany, Colonies, & Occupied Territories, 1872-1945
Edited by PostmasterGS - 09/17/2020 7:38 pm
Pillar Of The Community
Learn More...
Canada
578 Posts
Posted 09/17/2020   8:06 pm  Show Profile Bookmark this reply Add itma to your friends list  Get a Link to this Reply
Well, that's strange, It happens with me on three different devices, each with its own OS. Just to make sure, when you go back from the upload window to the editing window, you did NOT click the close window button.
Send note to Staff  Go to Top of Page
Pillar Of The Community
Japan
2287 Posts
Posted 09/17/2020   8:24 pm  Show Profile Bookmark this reply Add PostmasterGS to your friends list  Get a Link to this Reply
Are you trying to get back to the already open upload window by clicking "Upload Image" again?

Firefox apparently handles window focus differently. If the window is already open, clicking "Upload Image" doesn't do anything because the window is already open. Other browsers (Chrome, Brave) will change the focus to the already open window.

In Firefox, I am still able to get to the already open "Upload Image" window and use it simply by selecting it with my mouse or selecting it from "Window" on the toolbar.
Send note to Staff  Go to Top of Page
Presenting the GermanStamps.net Collection - Germany, Colonies, & Occupied Territories, 1872-1945
Pillar Of The Community
Learn More...
Canada
578 Posts
Posted 09/18/2020   09:49 am  Show Profile Bookmark this reply Add itma to your friends list  Get a Link to this Reply
Well, Don, I guess I have to apologize for yesterday's wild goose chase. This morning, I just can't replicate the problem. I might have thought that my brain was playing tricks on me had it not been for an orphaned Upload window left over from yesterday. I could see it when I clicked the Firefox icon in the task bar but it was totally unresponsive. It took Program Manager to close it.

As a bit of a postscript, before I and my partners sold our company and retired (we made fax systems and also offered a fax service) I was always given beta copies of our User Interface as I was the most likely person to break it.

Frank.
Send note to Staff  Go to Top of Page
Edited by itma - 09/18/2020 09:51 am
  Previous TopicReplies: 6 / Views: 256Next Topic  
 
To participate in the forum you must log in or register.


Go to Top of Page
Disclaimer: While a tremendous amount of effort goes into ensuring the accuracy of the information contained in this site, Stamp Community assumes no liability for errors. Copyright 2005 - 2020 Stamp Community Family - All rights reserved worldwide. Use of any images or content on this website without prior written permission of Stamp Community or the original lender is strictly prohibited.
Privacy Policy / Terms of Use    Advertise Here
Stamp Community Forum © 2007 - 2020 Stamp Community Forums
It took 0.19 seconds to lick this stamp. Powered By: Snitz Forums 2000 Version 3.4.05