Stamp Community Family of Web Sites
Thousands of stamps, consistently graded, competitively priced and hundreds of in-depth blog posts to read
Stamp Community Forum
 
Username:
Password:
Save Password
Forgot your Password?

Welcome Guest! Need help? Got a question? Inherit some stamps?
Our stamp forum is completely free! Register Now!

SCF Slow To Load At Times

 
Next Page    
 
To participate in the forum you must log in or register.
Author  Topic Next Topic
Page: of 7
Pillar Of The Community
Learn More...
United States
2430 Posts
Posted 02/02/2019   06:55 am  Show Profile Bookmark this topic Add angore to your friends list Get a Link to this Message
As of late, SCF is slow to load at times. It may take up to 5 seconds before anything loads with the "waiting" message in status bar.

I use two different computers and see this behavior on both. I do not see it with other web sites.
Send note to Staff
Al
Edited by angore - 02/02/2019 07:34 am

Moderator
Learn More...
6929 Posts
Posted 02/02/2019   07:10 am  Show Profile Check 51studebaker's eBay Listings Bookmark this reply Add 51studebaker to your friends list  Get a Link to this Reply
I have gotten some calls and have also noticed some performance issues. I have not discussed them with Bobby but my opinion is that it may be related to the SCF search feature. As the database has grown over the last decade, I assume that the total number of posts is in the hundreds of thousands. Running a full text search on this number of posts on a SQL server is very 'expensive'. Looping through an index of this size sucks the resources right out of a server.

I also assume that this is why Bobby added the Google search feature to the SCF search page; it off loads the search burden from the SCF server and on to the Google server. Throwing a large amount of money on a new server, perhaps splitting it across multiple servers, would greatly help.

So my theory is that when another user(s) leans hard on the SCF search feature, it is impacting the rest of the server performance. Perhaps Bobby will weight in later today and correct my assumptions if they are wrong.
Don
Send note to Staff  Go to Top of Page
Forum Dad
USA
1460 Posts
Posted 02/02/2019   09:31 am  Show Profile Bookmark this reply Add bobby131313 to your friends list  Get a Link to this Reply
Don is exactly right. Searches and subscriptions are the most taxing things on the site.

With that said... 95% of the time my pages are output in .3 seconds or less.
Send note to Staff  Go to Top of Page
Valued Member
United States
200 Posts
Posted 02/02/2019   1:25 pm  Show Profile Bookmark this reply Add dsmith426 to your friends list  Get a Link to this Reply
In the last week I also have been experiencing slow load times and even timeouts just trying to a page up (not doing a search) Trace routes don't show abnormal delay so its something with the server.
Send note to Staff  Go to Top of Page
Valued Member
United States
200 Posts
Posted 02/02/2019   1:30 pm  Show Profile Bookmark this reply Add dsmith426 to your friends list  Get a Link to this Reply
Or are you saying its slow because I try to get a page at the same moment the server is doing a search for someone else?

PS: It took over a minute to get to load this page to reply but the first reply there was no delay. Maybe look at throttling the cpu for the search process?
Send note to Staff  Go to Top of Page
Forum Dad
USA
1460 Posts
Posted 02/02/2019   1:32 pm  Show Profile Bookmark this reply Add bobby131313 to your friends list  Get a Link to this Reply
Don't worry about loading time, I can't control that. Look at the time at the bottom of the page.
Send note to Staff  Go to Top of Page
Valued Member
United States
200 Posts
Posted 02/02/2019   1:38 pm  Show Profile Bookmark this reply Add dsmith426 to your friends list  Get a Link to this Reply
It took 52.2 seconds to lick this stamp.
Send note to Staff  Go to Top of Page
Pillar Of The Community
United States
6375 Posts
Posted 02/02/2019   1:46 pm  Show Profile Bookmark this reply Add Petert4522 to your friends list  Get a Link to this Reply
I have no trouble - it took .44 seconds to lick this stamp!

Peter
Send note to Staff  Go to Top of Page
Valued Member
United States
200 Posts
Posted 02/02/2019   2:05 pm  Show Profile Bookmark this reply Add dsmith426 to your friends list  Get a Link to this Reply
It's a sporadic issue. Most of the time its fine for me. I know if you click on a username that has a higher likelihood of a slow response - but even that is speedy at the moment.
Send note to Staff  Go to Top of Page
Valued Member
United States
200 Posts
Posted 02/06/2019   02:50 am  Show Profile Bookmark this reply Add dsmith426 to your friends list  Get a Link to this Reply
If you're using that time as telemetry it is invalid data.

Got interesting result here. How are you calculating the seconds to lick the stamp?

I tried doing a search - which just ran for a very long delay so then I tried to open a post in another tab to read while I waited and it too was taking forever. What seemed like approaching the 2 minute mark, both pages finished loading at the same time. I went to look at the times so I could post them here:

The search page was a white page and in red it said "Sorry, there was an error processing this page." (no time listed)

And the other page? It said .51 seconds which is totally wrong by 100x at least.


Send note to Staff  Go to Top of Page
Edited by dsmith426 - 02/06/2019 02:56 am
Pillar Of The Community
Learn More...
United States
2430 Posts
Posted 02/06/2019   07:57 am  Show Profile Bookmark this reply Add angore to your friends list  Get a Link to this Reply
My issue has been inconsistent. Most of the time it is fine but I have also got the same error as dsmith.
Send note to Staff  Go to Top of Page
Al
Forum Dad
USA
1460 Posts
Posted 02/06/2019   09:38 am  Show Profile Bookmark this reply Add bobby131313 to your friends list  Get a Link to this Reply

Quote:
If you're using that time as telemetry it is invalid data.


No, it's not. I said earlier, "Don't worry about loading time, I can't control that. Look at the time at the bottom of the page."

That is the time it took for the server to output the page. The server has zero control over how long it takes to get over the internet to your device. There's a million variables affecting that, including your device itself and browser.
Send note to Staff  Go to Top of Page
Bedrock Of The Community
Learn More...
Australia
26617 Posts
Posted 05/24/2019   8:20 pm  Show Profile Bookmark this reply Add rod222 to your friends list  Get a Link to this Reply
Interesting read.
I have been getting timeouts often of late.
Maybe Chrome.


Quote:
added the Google search feature to the SCF search page;


Sometimes I accidentally hit the lower SCF search, and with one word, can take some time. Ergo try and remember to type in the Top search first.
Send note to Staff  Go to Top of Page
Edited by rod222 - 05/24/2019 8:23 pm
Pillar Of The Community
Australia
1141 Posts
Posted 05/24/2019   8:29 pm  Show Profile Bookmark this reply Add Bobby De La Rue to your friends list  Get a Link to this Reply
I've had the odd timeout and pages slow to load too.

I'm running Firefox.
Send note to Staff  Go to Top of Page
Bedrock Of The Community
Learn More...
Australia
26617 Posts
Posted 05/24/2019   11:52 pm  Show Profile Bookmark this reply Add rod222 to your friends list  Get a Link to this Reply
I do not have a land line Bobby,
only a wi-fi dongle, although it gives reasonable service.
I see Telstra is just releasing its 5G network, only as router format, from what I can see.



Send note to Staff  Go to Top of Page
Pillar Of The Community
Learn More...
United States
2430 Posts
Posted 05/25/2019   06:08 am  Show Profile Bookmark this reply Add angore to your friends list  Get a Link to this Reply
Over the last few days. I have also seen the very slow to load issue.
Send note to Staff  Go to Top of Page
Al
Edited by angore - 05/25/2019 06:20 am
Page: of 7  Topic Next Topic  
Next Page
 
To participate in the forum you must log in or register.
Go to Top of Page
Disclaimer: While a tremendous amount of effort goes into ensuring the accuracy of the information contained in this site, Stamp Community assumes no liability for errors. Copyright 2005 - 2019 Stamp Community Family - All rights reserved worldwide. Use of any images or content on this website without prior written permission of Stamp Community or the original lender is strictly prohibited.
Privacy Policy / Terms of Use    Advertise Here
Stamp Community Forum © 2007 - 2019 Stamp Community Forums
It took 1.17 seconds to lick this stamp. Powered By: Snitz Forums 2000 Version 3.4.05